Volvo S60, S80, V70N (00-08), XC70 (00-08), XC90 (03-14) relaterade ämnen OBS! vid motorproblem försök att ange vad du har för motor i bilen...

Moderator: Moderatorer

av Andreas12
#1381611
Har en v70 06.
Hastighetsmätaren får för sig att visa allt från 5-20 kan/h mer än aktuell hastighet.
När detta händer och jag stannar visar mätaren tex 20 km/h .
Den visar även detta när bilen är avstängd och låst.
Men nollställer sig efter en stund.
Felet börjar komma mer ofta .
Någon som upplevt detta?
Fel på bcm?
Har inga felkoder .
av MickeM
#1381697
Snarare fel på DIM än BCM.
Eftersom den visar 20km/h stillastående, och jag antar att den inte tickar vidare på trippmätaren...
av Andreas12
#1381704
Osäker på om trippen rör sig.
Är min sambo som använder bilen så ser den väldigt sällan.
Förstår hur du tänker men då borde väl fler saker flippa ut?
Här är det bara hastigheten ..
Så Bcm bryter elen när tändningen stängs?
Prova plocka säkring 1 o 2 som ska vara till ABS
O inget hände där, det borde det gjort kanske om Bcm klyddat?
Funkar det att byta mätarehus utan klydd på dom? Såklart med rätt nr.
av Erik Å
#1381709
Låter som om mjukvaran försöker kompensera bort något slags (inbillat) mätfel.
Jag skulle ha kastat ett öga på abs-kransarna, om det nu finns några. De försvann på senare årgångar..
av MickeM
#1381727
Erik Å skrev: mån 25 maj 2020, 08:11 Jag skulle ha kastat ett öga på abs-kransarna, om det nu finns några. De försvann på senare årgångar..
Kransarna borde vara oskyldiga eftersom mätaren visar 20/km hastighet fast bilen står stilla och motor av.
Då kvittar det hur dåliga kransarna är.
Inget rör sig förbi sensorn ändå.

Jag är ganska säker på att det är fel i själva mätaren som sitter i DIM.

Skulle BCM få "spunk" och ge hastighetsinformation till DIM trots att INGA signaler kommer ifrån någon ABS-sensor, skulle vägmätaren ticka också i DIM.

OBS, att jag inte har provat, men jag tvivlar på att hastighetsmätaren rör sig alls om man rullar en avstängd bil. Dvs tändning av.
Sannolikt, är BCM nerstängd, och DIM tar inte emot signalen och än mindre rör visaren.
Men jag fick lust att prova den teorin nästa gång jag ska åka. Naturligtvis med rattlåset i åtanke.
av Erik Å
#1381775
Du har säkert rätt. Visarna drivs av små stegmotorer som i sin tur styrs av mikroprocessorer. När man startar så körs antagligen stegmotorn mot "0" för att hitta ett definierat läge. Sen måste processorn hålla reda på exakt hur många steg den lyfter respektive sänker visaren så kommer det att bli rätt. MEN om stegmotorn skulle kärva så att den hoppar över pulser eller om det är något lödfel så att inte alla pulser kommer fram så kommer visaren att hamna "vilse" och felet blir kvar när man stänger av..
av Andreas12
#1381776
Erik Å skrev:Du har säkert rätt. Visarna drivs av små stegmotorer som i sin tur styrs av mikroprocessorer. När man startar så körs antagligen stegmotorn mot "0" för att hitta ett definierat läge. Sen måste processorn hålla reda på exakt hur många steg den lyfter respektive sänker visaren så kommer det att bli rätt. MEN om stegmotorn skulle kärva så att den hoppar över pulser eller om det är något lödfel så att inte alla pulser kommer fram så kommer visaren att hamna "vilse" och felet blir kvar när man stänger av..
Det låter logiskt.
Den har ju på senare tid hamnat på olika hastigheter, allt från 5-20 km/h.
Plockade ut huset för o kolla nr på det ifall man springer på ett beg, när jag ändå rota där kolla jag om jag såg något uppenbart fel på lödningarna men såg inget fel.
Ska hålla ett öga på om trippmätaren ändrar sig oxå när det händer igen.
av Andreas12
#1383338
MickeM skrev: mån 25 maj 2020, 01:09 Snarare fel på DIM än BCM.
Eftersom den visar 20km/h stillastående, och jag antar att den inte tickar vidare på trippmätaren...
Verkar som du hade rätt.
Damsög skrotarna här efter ett mätarhus men var svårare o hitta än jag trodde.
Hitta tillslut ett från en 05a som låg slängd i en annan bil.
Har nu kört någon vecka och det verkar funka som det ska, bilen tappa 10.000 mil på köpet ;-)
300 kr och det verkar fungera kalas.
av MickeM
#1383432
Du får en felkod i CEM som säger att bilen har felaktig mätarställning.
Ha det i åtanke om bilen ska säljas.

Fungerade den verkligen rakt över från annan bil utan någon som helst åtgärd?
Jag trodde inte den skulle accepteras i nätverket plug and play.
Jag TRODDE också att DIM skulle ta det högsta lagrade miltalet från Can-noderna miltalet lagras i.

Men felkoden har jag sett i flera my02, eftersom DIM problem är vanligt på dom.
Ovanligt efter 2004.
av Andreas12
#1384025
MickeM skrev: fre 05 jun 2020, 11:46 Du får en felkod i CEM som säger att bilen har felaktig mätarställning.
Ha det i åtanke om bilen ska säljas.

Fungerade den verkligen rakt över från annan bil utan någon som helst åtgärd?
Jag trodde inte den skulle accepteras i nätverket plug and play.
Jag TRODDE också att DIM skulle ta det högsta lagrade miltalet från Can-noderna miltalet lagras i.

Men felkoden har jag sett i flera my02, eftersom DIM problem är vanligt på dom.
Ovanligt efter 2004.
Ja jag skrev upp mätarställningarna i serviceboken, är ju inte bara ur försäljningssyfte utan även kamrem mm.
Vad jag fick fram så när det gäller faceliften är det bara plugga in en ny sålänge den är från 05-07 o det stämde bra.
Dom äldre verkar vara annorlunda , kom nytt elsystem på 05 så kanske det ändrades .
Mätarhuset är från en tidig 05a enl stämpling på baksidan.
Trodde oxå den skulle visa det högsta men den verkar tagit all info från dim.
Lite komiskt att det var just detta man ville slippa när man valde faceliften men nu hoppas jag det håller .
B23A trimma

Hej jag har ganska nyligen köpt en kanonfin 2[…]

Halvljus elfel 850 -92

Är det båda strålkastarna som &qu[…]

Låg nivå bromsvätska.

Hoppas han skojar! Bromsvätska behållar[…]